Loess.ru

having fun

Wireguard VPN added to 5.6 kernel

https://www.opennet.ru/opennews/art.shtml?num=52636

Представлен знаковый выпуск VPN WireGuard 1.0.0, который отметил собой поставку компонентов WireGuard в основном составе ядра Linux 5.6 и стабилизацию разработки. Включённый в состав ядра Linux код прошёл дополнительный аудит безопасности, выполненный независимой фирмой, специализирующейся на подобных проверках. Аудит не выявил каких-либо проблем.

Напомним, что VPN WireGuard реализован на основе современных методов шифрования, обеспечивает очень высокую производительность, прост в использовании, лишён усложнений и хорошо зарекомендовал себя в ряде крупных внедрений, обрабатывающих большие объёмы трафика. Проект развивается с 2015 года, прошёл аудит и формальную верификацию применяемых методов шифрования. Поддержка WireGuard уже интегрирована в NetworkManager и systemd, а патчи для ядра входят в базовый состав дистрибутивов Debian Unstable, Mageia, Alpine, Arch, Gentoo, OpenWrt, NixOS, Subgraph и ALT.

Размещённые на сайте проекта результаты тестирования охватывают старую обособленную реализацию WireGuard и отмечены как недостаточно качественные. Со времени проведения тестов код WireGuard и IPsec был дополнительно оптимизирован и теперь работает быстрее. Более полное тестирование, охватывающее интегрированную в ядро реализацию, пока не проведено. Тем не менее, отмечается, что WireGuard в некоторых ситуациях по-прежнему обгоняет IPsec в силу многопоточности, в то время как OpenVPN остаётся очень медленным.

Это (тоже) помешало планам собянина установить цифровой концлагерь в Москве

Депутат МГД Тарасов озвучил все о самоизоляции и QR кодах, инфекционных больницах и ЧС, а самое главное, о законности всего происходящего с трибуны Мосгордумы:

«Правовые новообразования»



— вовочка пообещал месяц «нерабочих дней с сохранением зарплаты»
«Итак, Путин думает только о том, как сохранить свой рейтинг и не брать на себя ответственность.
Поскольку делать все-таки что-то надо, а Кремль молчит — российские регионы вынужденно ориентируются на мэра Москвы Сергея Собянина, который первым ввел жесткие карантинные меры. »
«Удивительно, конечно.
Чувак 20 лет строил «вертикаль власти», а как жареный петух клюнул — втопил за федерализацию так, как никакому Ельцину не снилось.
Буквально же вот «берите столько суверенитета сколько сможете».
Жалкий, испуганный, никакой.»
— https://t.me/leonid_volkov

Mikrotik IPSec + Android PSK XAuth

quick and dirty, по мотивам https://wiki.mikrotik.com/wiki/Manual:IP/IPsec :

/ip ipsec peer
add name=mobile passive=yes
/ip ipsec profile
set [ find default=yes ] enc-algorithm=camellia-192,aes-128,3des
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=camellia-192,aes-128-cbc,3des
/ip pool
add name=ipsec ranges=private.ip.range/mask #ip range, "выдаваемый" подключенным клиентам Read More

Чёрный лебедь приплыл


^^ и это уже второй раз за неделю, но теперь и:

Из-за пандемии коронавируса закрывают города по всей планете, отменяют сообщение, в т.ч. и грузовой транспорт.
А в России как всегда: https://novayagazeta.ru/articles/2020/03/09/84231-geroy-dna (pdf)
Нефть ёбнулась до 32$/брент.
Спасибо, что живой X)

Arcanum OST


Soundtrack Credits
------------------

Arcanum: Of Steamworks & Magick Obscura
Original Computer Game Soundtrack
Music Composed by Ben Houge

Leonid Keylin, violin I
Kathy Stern, violin II
Vincent Comer, viola
Susan Williams, cello

Evan Buehler, marimba on "Qintarra"
Ben Houge, djembe and rainstick on "Qintarra;"
synthesizer on "The Wheel Clan," "The Void," and "Kerghan's Castle"

Recorded and mixed by Sam Hofstedt and John Burton at Studio X, Seattle, WA.
Percussion overdubs recorded by Mike Caviezel at Sierra Studios, Bellevue, WA.
Synthesizer tracks recorded by Ben Houge at Sierra Studios, Bellevue, WA.
Remixed and digitally edited by Ben Houge and Mike Caviezel.

Soundtrack produced by Ben Houge and Jeff Pobst.

You can read Ben Houge’s notes and comments on the soundtrack here:
http://www.benhouge.com/arcanum.html
Автор даже ноты выложил на своём сайте. Это эпичный альбом, не замеченный никем, кроме почитателей Arcanum.
Arcanum OST Lossless download at
wav http://www.terra-arcanum.com/downloads/arcanum/Arcanum_OST_Lossless.exe
flac cd rip https://rutracker.org/forum/viewtopic.php?t=1531750

Кстати, в 18 году вышла сборка Arcanum multiverse edition. Должна решать все проблемы и делать сочной игру двадцатилетней выдержки.
https://boosty.to/multiverse_team
https://rutracker.org/forum/viewtopic.php?t=5213556